I suggest you ...

Kindle Fire (2nd gen)

The game is great on Kindle Fire (1st Gen), but I am unable to play it on my Kindle Fire (2nd Gen.). I would love it if you could make an app that is compatible!

1 vote
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    completed  ·  AdminJerome Lacoste (Support) (Admin, DragonBox) responded  · 

    Hello!

    We’ve submitted our fixed DragonBox 12+ to Amazon. Version 2.0.5 and above should contain the fix. It is online.

    To check the version currently in use, see http://www.amazon.com/gp/product/B00CEK37K4/ref=mas_dl?ie=UTF8&mas_redir=C&ref=mas_dl

    As for the 5+, we haven’t been reported any issues. Please contact our support for specifics!

    Note this part of the support site isn’t meant for troubleshooting issues or answering specific questions, but for new ideas !

    Thanks!

    Jerome

    3 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Anonymous commented  ·   ·  Flag as inappropriate

        Thanks for the response. It isn't clear to me if the bugs in the 5+ version are also fixed. If I need to start with 5+ levels are they included in the 12+ version? Could I skip the 5+ version altogether?

      • Anonymous commented  ·   ·  Flag as inappropriate

        I've been checking Amazon for a week. I don't see the new version and I don'twant to buy unless I know the new version will be there for upgrade.

      • Andrea commented  ·   ·  Flag as inappropriate

        Completely agree! I'd buy it in a second! Please update this for the Kindle Fire HD (2nd Generation)

      Feedback and Knowledge Base