DragonBox EDU System Requirements

Online version of DragonBox EDU requirements:

The online version of DragonBox EDU requires the installation of the Unity WebPlayer Plugin.

The Unity WebPlayer requires a graphics card compatible with DirectX 9.0x. Please note that the version of DirectX that your video card supports can be misleading. The Steam Support Site has a very good explanation of the problem.

NOTE! Unity Webplayer only works with newer browsers. Internet explorer 9 or later is required. We recommend the latest version of Firefox or Google Chrome.


iOS version of DragonBox EDU requirements:

iOS 6 or later

Feedback and Knowledge Base